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KATA PENGANTAR 

 

Puji Syukur kehadirat Tuhan Yang Maha Esa karena atas rahmat dan hidayah-Nya kami 

telah berhasil menyusun Modul Bimbingan Teknis Penguatan Simpul Jaringan Analisis 

Spasial Dasar. Modul ini disusun dalam rangkaian 3 seri pembelajaran yang ditulis sebagai 

bahan dalam pelaksanaan bimbingan teknis penguatan simpul jaringan. 

Penyusunan modul ini tidak terlepas dari bantuan berbagai pihak, karena beberapa 

bagian pada modul ini merujuk pada Modul Pelatihan Balai Diklat Badan Informasi 

Geospasial maupun dari beberapa sumber ajar yang telah tersedia. 

Modul ini diharapkan dapat meningkatkan kapasitas pengetahuan dan keterampilan 

sumber daya manusia (SDM) di bidang pemetaan dan sistem informasi geografis bagi 

pihak-pihak terkait dalam rangka pendampingan dan penguatan simpul jaringan baik di 

tingkat daerah maupun pusat. Peningkatan kapasitas ini sangat penting artinya dalam 

mendukung pengumpulan, pengelolaan data dan informasi geospasial, sehingga sasaran-

sasaran kegiatan Pendampingan dan Penguatan Simpul Jaringan di daerah lebih optimal.  

Kami berharap, sumbangsih kecil kami ini bisa bermanfaat bagi peningkatan sumber daya 

manusia untuk sekarang dan masa depan.  

 

Cibinong, Juni 2023 

Penyusun 
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I. PENDAHULUAN 

1.1. Latar Belakang 

Sistem Informasi Geografis (SIG) adalah suatu sistem yang dirancang untuk mengelola informasi 

geografis baik yang bersifat spasial, non spasial maupun keduanya. SIG mempunyai kemampuan 

dalam menjawab pertanyaan berbagai permasalahan yang berkaitan dengan keruangan, untuk 

memberikan dasar acuan dalam pengambilan keputusan.  

 

Pemanfaatan SIG telah banyak digunakan oleh berbagai pihak seperti pemerintahan, militer, 

politik maupun bisnis. Meningkatnya penggunaan SIG dalam berbagai bidang dikarenakan 

semakin meningkatnya kemampuan SIG dalam mengelola informasi geografis serta didukung 

oleh kemajuan yang pesat dalam bidang komputer, teknologi informasi, penginderaan jauh serta 

teknologi penentuan posisi.  

 

Salah satu kemampuan SIG yang tidak dimiliki oleh sistem informasi yang lainnya ialah 

kemampuan dalam melakukan pengolahan data spasial menggunakan alat (tool) geoprocessing. 

Kemampuan inilah yang menjadikan SIG dapat menjawab berbagai pertanyaan yang berkaitan 

dengan permasalahan keruangan.  

 

Karena pentingnya analisis spasial dasar dalam SIG, seringkali keberadaan geoprocessing ini 

menjadi tolok ukur dalam hal melihat kemampuan perangkat lunak SIG, dengan kata lain semakin 

banyak alat geoprocessing maka semakin canggih perangkat lunak tersebut. Analisis spasial dasar 

digunakan untuk melakukan pekerjaan dalam SIG dari yang paling sederhana seperti membuat 

buffer atau melakukan overlay poligon hingga analisis regresi yang kompleks. Dengan kata lain, 

setiap perubahan atau ekstraksi informasi pada data SIG akan melibatkan geoprocessing. 

1.2. Deskripsi Modul 

Modul Analisis Spasial Dasar ini secara umum membahas tentang penggunaan tools dalam 

melakukan analisis spasial.  

1.3. Tujuan Pembelajaran 

Dengan mempelajari dan mempraktekkan modul ini, maka peserta latih pada akhir modul ini 

diharapkan mampu :  

a) Mampu menjelaskan konsep analisis spasial dasar 

b) Mampu menjelaskan tentang geoprocessing 

c) Mampu melakukan pengolahan data geospasial menggunakan alat geoprocessing   
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II. ANALISIS SPASIAL DASAR 

 

2.1. Analisis Spasial Dasar 

Analisis spasial merupakan kumpulan – kumpulan dari teknik yang dapat digunakan untuk melakukan 

pengolahan data SIG. Hasil dari analisis data spasial sangat bergantung dari lokasi atau tempat di mana 

objek sedang dianalisis. Selain itu, analisis spasial juga bisa diartikan sebagai teknik – teknik yang dapat 

digunakan untuk meneliti dan juga mengeksplorasi dari dari sudut pandang keruangan. Semua teknik 

ataupun pendekatan perhitungan secara matematis yang berhubungan dengan data keruangan atau 

spasial dilakukan dengan menggunakan fungsi analisis spasial. 

Menurut Eddy Prahasta (2009), fungsi dari analisis spasial yaitu: 

1) Klasifikasi (Reclassify), yaitu suatu kegiatan yang mengklasifikasikan kembali suatu data hingga 

pada akhirnya menjadi sebuah data spasial yang baru dan berdasarkan pada kriteria atau 

atribut tertentu.  

2) Jaringan atau Network, yaitu sebuah fungsionalitas yang merujuk pada data – data spasial 

titik- titik ataupun garis – garis sebagai jaringan yang tidak terpisahkan. 

3) Overlay, merupakan fungsionalitas yang menghasilkan layer data spasial baru, di mana layer 

tersebut merupakan hasil dari kombinasi minimal dua layer yang menjadi masukkannya. 

4) Buffering, adalah fungsi yang akan menghasilkan layer spasial baru menghasilkan layer data 

spasial baru dengan bentuk poligon serta memiliki jarak tertentu dari unsur – unsur spasial 

yang menjadi masukkannya. 

5) 3D Analysis, fungsi ini terdiri atas sub – sub fungsi yang berkaitan dengan presentasi data 

spasial yang terdapat di dalam ruang 3 dimensi atau permukaan digital. 

6) Digital Image Processing, untuk fungsionalitas ini nilai ataupun intensitas dianggap sebagai 

fungsi sebar atau spasial. 

 

2.2. Definisi Geoprocessing 

Secara sederhana Geoprocessing didefiniskan sebagai seperangkat alat untuk memproses data 

geografis atau ada juga yang mendefinisikan Geoprocessing sebagai salah satu operasi dalam SIG yang 

berfungsi untuk memanipulasi data geografis. Tujuan utama dari Geoprocessing adalah menyediakan 

alat untuk melakukan analisis dan mengelola data geografis. Geoprocessing menyediakan seperangkat 

alat untuk melakukan pekerjaan dalam SIG dari yang paling sederhana seperti membuat buffer atau 

melakukan overlay poligon hingga analisis regresi yang kompleks. Dengan kata lain, setiap perubahan 

atau ekstraksi informasi pada data SIG akan melibatkan geoprocessing. 

Sejalan dengan perkembangan teknologi perangkat lunak SIG dan teknologi komputer serta semakin 

berkembangnya alat yang dikembangkan, geoprocessing sekarang bukan hanya sekedar berkaitan 

Indikator Keberhasilan 

Setelah menyelesaikan bab ini, peserta latih mampu: 

• Menjelaskan analisis spasial dasar 

• Menjelaskan geoprocessing 

• Menjelaskan jenis alat geoprocessing 

• Menjelaskan fungsi geoprocessing dalam analisis spasial dasar 
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dengan alat untuk mengolah data SIG tetapi sudah merupakan kerangka kerja (framework) dalam 

pekerjaan SIG. Pemahaman kerangka kerja dikarenakan geoprocesssing bukan hanya sekedar alat-alat 

yang terpisah melainkan sekumpulan jendela, kotak dialog dan prosedur yang terintegrasi untuk 

mengelola dan menjalankan alat. Dengan kemampuan ini akan mempermudah dan mempercepat 

untuk menentukan alur kerja, alat yang akan digunakan, eksekusi alat, pengelolaan data, modifikasi 

data, dokumentasi hasil dan berbagi pakai hasil analsis.  

Karena pentingnya geoprocessing ini dalam SIG, seringkali kemampuan ini menjadi tolok ukur dalam 

hal melihat kemampuan perangkat lunak SIG, dengan kata lain semakin banyak alat geoprocessing 

yang dimiliki perangkat lunak maka semakin canggih perangkat lunak tersebut. 

Pengetahuan mengenai prosedur dan metode dari alat geoprocessing yang digunakan sangat 

diperlukan sehingga akan memiliki pemahaman yang lebih luas dan lebih dalam tentang bagaimana 

dan mengapa menggunakan geoprocessing. 

Secara umum alat geoprocessing dalam GIS menggunakan pola yang sama: input data, alat yang 

digunakan dengan serangkaian opsi dan parameter yang didefinisikan serta output data hasil dari 

proses geoprocessing. Seperti yang diilustrasikan pada Gambar 1.  

 

Gambar 1. Proses Geoprocessing 

2.3. Jenis Alat Geoprocessing 

Seperti yang telah disampaikan pada bab sebelumnya bahwa tool geoprocessing sangat banyak mulai 

dari yang paling sederhana sampai kepada kebutuhan untuk analisis spasial yang komplek dan rumit. 

Saat ini telah banyak dikembangkan berbagai alat geoprocessing maupun metode untuk membantu 

dalam pekerjaan SIG, terutama pada kemampuan perangkat lunak SIG untuk melakukan analisis 

spasial. Namun karena banyaknya perangkat lunak SIG, serta dengan penekanan atau tujuan yang 

berbeda dalam pengembangannya, seringkali nama dari alat tersebut agak berbeda satu sama lain 

walaupun fungsinya sama. 

Secara umum alat dalam geoprocessing dibagi kedalam enam kategori, yaitu alat: 

1. Analisis Overlay 

2. Analisis Proximity 

3. Pengolahan dan Analisis Tabel 

4. Analisis Permukaan 

5. Analisis Statistik 

6. Seleksi dan Ektraksi 

Dalam bagian, kita akan melihat setiap kategori secara umum serta dengan beberapa fungsi alat yang 

umum digunakan di setiap kategori, bukan dengan tujuan menghafal bagaimana fungsi masing-masing 

alat, tetapi untuk memahami bagaimana kategori alat beroperasi untuk membangun dasar 

pemahaman geoprosesing.  

Input Proses Output
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Dengan memiliki dasar pemahaman alat geoprosesing akan memudahkan untuk memahami berbagai 

macam alat geoprosesing lainnya, tidak membatasi hanya pada alat yang dipelajari dalam pelatihan 

atau modul ini. Kemampuan untuk membangun keterampilan pemahaman geoprosesing yang kuat 

adalah kunci untuk menjadi seorang analis SIG yang handal. 

2.3.1 Overlay Analysis 

Salah satu pertanyaan yang sering dikemukakan dalam SIG adalah “Apa yang ada di atas apa?” 

contohnya: 

1. Apa pengunaan lahan diatas suatu jenis tanah? 

2. Persil-persil mana saja yang dibangun diatas dataran banjir? 

3. Jalan apa yang ada didalam suatu kabupaten? 

4. Apakah terdapat galian tambang pada kawasan lindung? 
 

Untuk menjawab pertanyaan-pertanyaan diatas dalam SIG digunakan alat geoprocessing yaitu 

overlay (tumpang susun). Overlay digunakan unttuk menggabungkan beberapa karakteristik dari 

beberapa dataset menjadi satu, , sehingga overlay dapat digunakan untuk mencari lokasi atau 

area spesifik dari suatu kumpulan nilai atribut sesuai dengan kriteria yang dibutuhkan (Gambar 

2). Pada umumnya terdapat dua metode untuk melakukan analisis overlay, yaitu overlay data 

vektor (melakukan overlay pada titik, garis dan polygon) dan overlay data raster.  

Fungsi overlay pada data vektor ialah membagi fitur yang ada di layer input dimana layer tersebut 

akan overlap (ditumpuk) dengan fitur-fitur yang ada di layer overlay. Proses tersebut akan 

menghasilkan fitur baru yang lalu akan disimpan sebagai output layer sehingga layer input dan 

layer overlay aslinya tidak akan terganggu/berubah. Data atribut pada fitur yang dioverlaykan 

akan secara otomatis terisi dan tersambung dan disimpan pada output layer. 

Pada overlay raster, setiap sel layer raster mereferensikan suatu lokasi geografis. Hal ini membuat 

raster overlay sangatlah cocok untuk menggabungkan karakteristik-karakteristik dari beberapa 

layer menjadi satu layer. Biasanya seuatu nilai numerik diberikan untuk masing-masing 

karakteristik, yang memungkinkan untuk secara matematis menggabungkan layer dan 

menetapkan nilai baru untuk setiap sel di output layer. 

 
Gambar 2. Tumpang Tindih (Overlay) 
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Pendekatan ini sering digunakan untuk menemukan lokasi yang cocok atau sesuai untuk 

penggunaan tertentu. Analisis Overlay juga sering digunakan bersamaan dengan analisis-analisis 

lainnya. Sebagai contoh analisis overlay dapat digunakan pada data yang berasal dari analisis 

proximity (Seperti buffer) atau analisis surface (Seperti slope atau aspect). Selain itu, data hasil 

analisis overlay juga sering dilanjutkan dengan analisis-analisis lainnya seperti ekstraksi untuk 

memilih suatu subset dari suatu fitur atau generalisasi.  

2.3.2 Proximity Analysis 

Alat proximity digunakan untuk melakukan analisis hubungan distibusi spasial antar fitur, 

pertanyaan yang sering ditanyakan pada SIG, seperti contoh di bawah ini: 

1. Seberapa dekat sumur ini dari tampat pembuangan sambah? 

2. Apakah ada jalan pada radius 1.000 meter dari suatu aliran? 

3. Berapa jarak dari dua lokasi ini? 

4. Apa hal yang paling jauh dan paling dekat dari fitur ini? 

5. Berapa jarak antar fitur di satu layer dan fitur di layer lainnya? 

6. Manakah jalan yang harus ditempuh dengan jarak terpendek jika ingin dari suatu tempat 

ke tempat lainnya? 
 

Pertanyaan tersebut di atas dapat dijawab dengan menggunakan alat geoprocessing proximity. 

Seperti juga pada alat overlay, alat proximity juga dibagi menjadi dua kategori, tergantung dari 

jenis inputnya datanya: vektor atau raster. 

Untuk data vector, alat proximity dapat digunakan untuk menemukan hubungan antar fitur. alat 

ini akan menghasilkan informasi dengan hasil berupa fitur area atau berupa data tabel. Salah satu 

alat proximity yang banyak digunakan ialah Buffer yang digunakan untuk menampikan suatu zona 

yang berada disekitar fitur tertentu atau menunjukan area tertentu dari suatu fitur. Sebagai 

contohnya tool buffer dapat digunakan untuk melihat zona yang terjangkau dalam radius 

tertentu atau dapat juga digunakan bersamaan dengan tool multyring buffer yang 

mengklasifikasikan area/zona disekiar suatu fitur berdasarkan interval jarak atau radius. 

Selain buffer, beberapa analisis yang dilakukan dengan menggunakan alat pada kategori 

proximity diantaranya : menghitung jarak dari satu titik di satu fitur ke titik lainnya di fitur yang 

berbeda, menghitung jarak dari suatu titik di suatu fitur ke semua titik yang berada dalam radius 

tertentu, membuat fitur polygon yang membagi ruang yang ada dan mengalokasikannya 

berdasarkan fitur poin terdekat, melakukan seleksi fitur-fitur berdasarkan jarak dari suatu fitur 

lainnya dan analisis jaringan, misalnya menghitung jarak terpendek dari suatu jaringan 

transportasi. 

Pada data raster alat proximity digunakan untuk menunjukan jarak dari masing-masing sel dari 

suatu fitur dengan sel yang dari fitur lainnya, menghitung jarak dan arah dari satu sel ke sel 

lainnya, membagi suatu area dan mengalokasikan masing-masing sel kedalam input fitur 

terdekat. Beberapa contoh dari analisis proximity dapat dilihat pada Gambar 3. 
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Gambar 3. Beberapa Contoh Analisis Kedekatan (Proximity Analysis) 

2.3.3 Pengolahan dan Analisis Tabel 

Kategori selanjutnya dari alat geoprocessing ialah alat yang digunakan untuk melakukukan 

pengolahan dan analisis tabel. Alat ini sangat diperlukan karena hampir seluruh data SIG disimpan 

dan dipresentasikan sebagai tabel basisdata yang memiliki informasi atribut (Gambar 4). 

Alat yang termasuk dalam katagori ini diantaranya : alat untuk menambah atribut baru, menyalin 

nilai dari satu tabel ke tabel lainnya, mengkorversikan tabel yang berisikan nilai koordinat menjadi 

suatu fitur ataupun menghubungkan satu tabel dengan tabel lainnya berdasarkan data atribut 

yang sama, menggabungkan data dari dua atau lebih tabel, membangun data spasial dari sebuah 

data tabular, menghitung jumlah dan frekuensi nilai kolom dari suatu fitur, menghitung jumlah 

record, melakukan penghitungan nilai pada field/kolom secara matematis. 

 
Gambar 4. Ilustrasi analisis tabel 
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2.3.4 Analisis Permukaan  

Sebelum kita membahas alat yang digunakan untuk membangun dan melakukan analisis 

permukaan (surface) ada baiknya kita lihat apa yang dimaksud dengan permukaan pada SIG. 

Permukaan pada SIG adalah data vector ataupun raster yang mempunyai nilai atribut disetiap 

lokasi pada luasan data tersebut. 

Permukaan dapat dipresentasikan dengan berbagai cara seperti kontur atau isoline, himpunan 

titik, TIN ( jaring segi tiga yang ditentukan oleh simpul (node) dan tepi (edge) yang menutupi suatu 

permukaan) dan raster; namun mayoritas analisis permukaan dalam SIG dilakukan pada data 

raster dan data TIN. Permukaan umumnya digunakan dalam sistem informasi geografis untuk 

memvisualisasikan fenomena seperti ketinggian, suhu, kemiringan, aspek, curah hujan, dan 

banyak lagi. Beberapa contoh analisis permukaan dapat dilihat pada Gambar 5. 

Berikut beberapa fungsi yang terdapat dalam kategori alat permukaan, diantaranya: untuk 

melakukan estimasi nilai pada lokasi yang tidak tersedia datanya (interpolasi), menghitung 

kepadatan pada suatu area, membangaun data raster yang berasal dari nilai data vector, 

membangun TIN, mengindikasikan kemiringan lereng, menghitung arah permukaan/lereng untuk 

setiap sel, melakukan analisis visibilitas suatu permukaan, menghitung volume permukaan, 

melakukan reklasifikasi nilai permukaan, melakukan analisis geostastistik, melakukan 

perhitungan aritmatika maupun logik pada data raster. 

 

Gambar 5. Beberapa contoh analisis permukaan (Surface Analysis) 

2.3.5 Analisis Statistik 

Analisis statisik dapat membantu untuk mengekstraksi informasi tambahan dari data SIG yang 

kemungkinan tidak didapatkan dengan hanya melihat peta secara visual seperti distribusi nilai 

atribut, tren pada suatu data spasial, atau apakah suatu fitur membentuk pola spasial (Gambar 

6). 
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Fungsi analisis statistik dalam SIG dapat dibagi menjadi dua yaitu nonspasial (tabular) atau spasial 

(terdapat informasi lokasi). Statistik nonspasial digunakan untuk menganalisis nilai atribut yang 

terkait dengan fitur, sedangkan statistik spasial menganalisis pola hubungan spasial antar fitur-

fitur seperti seberapa kompak atau seberapa terserbarnya suatu fitur, melihat apakah suatu fitur 

memilki kecenderungan mengarah pada orientasi tertentu dan apakah fitur-fitur tersebut 

membentuk kluster. Hubungan spasial biasanya didefinisikan sebagai jarak (seberapa jauh fitur 

dengan fitur lainnya) atau juga interaksi atau hubungan antar fitur.  

 

Gambar 6. Keluaran analisis statistik 

Analisis statistik sering digunakan untuk mengeksplorasi data, contohnya: untuk memeriksa 

distribusi nilai untuk atribut tertentu atau untuk mengenali outlier (nilai yang sangat tinggi atau 

rendah daripada yang lain). Informasi ini berguna ketika mendefinisikan kelas dan rentang pada 

peta, mengklasifikasi ulang data, atau saat mencari kesalahan pada data. 

Penggunaan lain dari analisis statistik adalah untuk meringkas data yang ada. Seringkali dilakukan 

untuk menghitung total area di setiap kategori penggunaan lahan. Atau dapat juga digunakan 

untuk membuat ringkasan spasial seperti menghitung ketinggian rata-rata untuk setiap Daerah 

Aliran Sungai (DAS). Data ringkasan berguna untuk mendapatkan pemahaman yang lebih baik 

tentang kondisi di suatu area secara keseluruhan. 

2.3.6 Seleksi dan Ekstraksi 

Alat analisis ekstraksi ditujukan untuk melakukan ekstraksi data yang besar menjadi yang lebih 

kecil baik untuk data vektor, raster maupun tabel. Dalam pekerjaan SIG seringkali kita 

mendapatkan data yang jauh lebih besar dan lebih kompleks dari pada yang kita perlukan. 

Sebagai contoh kita mendapatkan data dalam lingkup kabupaten padahal yang kita perlukan 

hanya pada level kecamatan, untuk meringkas data tersebut maka digunakan alat yang berkaitan 

dengan seleksi dan ekstraksi.  

Alat analisis ekstraksi tidak terbatas pada alat dan fungsi berbasis seleksi saja untuk mengurangi 

ukuran kumpulan data, tetapi juga dirancang untuk melakukan seleksi dan ekstraksi berdasarkan 

pada hubungan spasial (Gambar 7). 
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Gambar 7. Ilustrasi Analisis Ekstraksi dan Seleksi 

Beberapa fungsi dari alat ini diantaranya, untuk data vektor : memotong data, membagi data, agregasi 

data berdasarkan nilai atribut, eliminasi poligon melalui penggabungan, penggabungan poligon. 

Sedangkan untuk data raster, diantaranya: melakukan generalisasi data raster, pemotongan data 

raster, ekstraksi nilai raster berdasarkan fitur titik, membangun tabel berdasarkan nilai sel/piksel, 

melakukan pengaturan resolusi spasial data raster. 

2.4. Fungsi Geoprocessing dalam Analisis Spasial Dasar 

Dalam Sistem Informasi Geografis, terdapat dua istilah yaitu Geoprocessing dan Analisis Spasial, sering 

kali kedua istilah ini digunakan secara bergantian. Namun, kedua istilah ini sangat berbeda walaupun 

terkait satu sama lainnya. 

Analisis spasial adalah proses pemodelan yang mencakup metode dan teknis analisis menggunakan 

data geografis untuk mendapatkan informasi baru yang dapat mendukung dalam pengambilan 

keputusan. Analisis spasial juga identik dengan analisis geografis dan istilah saat ini yang sering 

digunakan ialah analisis geospasial. 

Proses analisis spasial dalam SIG melibatkan banyak langkah atau tahapan. Selama proses analisis 

berlangsung, model dibangun berdasarkan tujuan analisis kemudian setiap data keluaran dianalisis, 

divisualisasikan, ditafsirkan, dipahami, dimodifikasi, diperbarui, dikalibrasi, dan dieksekusi ulang. 

Sebagai gambaran umum bagaimana proses tahapan atau langkah dalam melakukan analisis spasial 

dapat dilihat pada langkah-langkah berikut ini:  

1. Membangun pertanyaan spasial serta menetapkan tujuan dari analisis spasial 

2. Penyiapan data 

3. Membangun model sesuai dengan tujuan  

4. Eksekusi model  

5. Melakukan evaluasi, visualisasi, penafsiran, rangkuman hasil analsis 

6. Membuat keputusan dan simpulan dari hasil analisis 

7. Menyajikan hasil analisis 
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Dalam proses analisis langkah-langkah tersebut bukan hanya dilakukan satu kali, tapi sering kali 

merupakan proses yang berulang untuk dapat mengeksplorasi, menafsirkan hasil dan 

menggunakannya untuk menarik kesimpulan serta membuat keputusan. 

Bagaimana dengan Geoprocessing? Dalam analisis spasial Geoprocessing merupakan langkah eksekusi 

dari serangkaian proses pada data geografis untuk membuat informasi baru. Proses ini meliputi 

diantaranya : analisis, visualiasi, penafsiran, modifikasi, pembaharuan, kalibrasi dan eksekusi ulang 

data awal maupun data turunan. Disamping itu Geoprocessing dapat melakukan otomatisasi banyak 

pekerjaan dalam SIG misalnya: persiapan data, konversi data, pemeriksaan integritas data, 

manajemen koordinat, otomatisasi alur kerja, manajemen data, produksi peta dan masih banyak lagi. 

Kemampuan Geoprocessing dalam melakukan otomatisasi serangkaian alur kerja sangat membantu 

untuk menghindari kebosanan dari pekerjaan yang berulang-ulang dalam SIG. Alur kerja ini dapat 

didokumentasikan dan dapat berbagi pakai dengan pengguna lainnya. 

Dengan demikian geoprocessing merupakan alat yang digunakan dalam proses analisis spasial. 

Penggunaanya tidak hanya terbatas pada proses analisis saja, tetapi keterlibatan geoprocessing 

digunakan mulai dari tahap persiapan data sampai dengan visualisasi hasil analisis. Disamping itu alat 

geoprocessing mampu melakukan otomatisasi dalam analisis spasial. 
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III. GEOPROCESSING PADA PERANGKAT LUNAK SIG (QGIS) 

 

Pada bagian ini kita akan membahas tentang alat geoprocessing pada perangkat lunak QGIS. Namun 

sebelum kita melangkah lebih dalam mengenai geoprocessing di ArcGIS ada baiknya kita mengenal 

beberapa tipe alat geoprocessing di QGIS 

 
Gambar 8. Tipe alat geoprocessing di QGIS 

 

3.1. BUFFER 

Alat Buffer mempunysi fungsi untuk menciptakan poligon pada jarak yang ditentukan di sekitar fitur, 

fitur ini bisa titik, garis atau poligon. Gambar 48 mengilustrasikan proses Buffer. 

 
Gambar 9. Proses Buffer 

Indikator Keberhasilan 

Setelah menyelesaikan bab ini, peserta latih mampu: 

1. Menjelaskan managemen alat geoprocessing di QGIS 

2. Menjelaskan pengoperasian alat geoprocessing di QGIS 

3. Menjelaskan pengaturan alat geoprocessing di QGIS 
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Sebagai contoh penggunaan alat Buffer, misalkan kita akan melakukan pelebaran jarak tertentu ke 

kanan dan ke kiri untuk dampak daerah aliran sungai. Berikut langkah-langkahnya: 

 

 

 

 

 

 

Gambar 10. Lokasi yang akan di Buffer 

1. Akses dengan klik menu Layer > add layer > add vector layer > vector > vector dataset: pilih 

file .shp yang akan ditampilkan, seperti gambar diatas 

2. Hasil yang akan didapat adalah sebagai berikut 

 

Gambar 11. File yang akan di buffer 

3. Sebelum memulai proses buffer, pastikan proyeksi yang digunakan adalah proyeksi geografis 

UTM zona 48S (sesuai zona UTM Kota Bogor). Untuk merubah proyeksi geografi caranya 

dengan klik Project > Properties > CRS: pada tab filter dapat diisi dengan “48S” atau “32748” 

(identifier EPSG untuk WGS84 Zone UTM 48S) > OK 
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Gambar 12. Pengaturan system referensi koordinat 

4. Klik kanan pada layer sungai > Export > Save Feature As > pilih format ESRI shapefile > isi nama 

file “sungai_utm.shp” > pilih CRS dengan proyeksi UTM zona 48S > OK. Hasilnya berupa layer 

sungai yang sudah dalam proyeksi UTM zona 48S. 

 

Gambar 13. Export hasil file sungai yang sudah menggunakan proyeksi UTM 

5. Lakukan buffer 

Klik Vector > Geoprocessing tools > Buffer > input layer: sungai_utm > distance: 100 meter > 

klik dissolve result > simpan dengan nama sungai_buffer.shp > Run. 
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Gambar 14. Proses buffer 

6. Hasil buffer adalah sebagai berikut 

 

Gambar 15. Hasil dari proses buffer 

3.2. CLIP 

Clip mempunyai fungsi untuk memotong layer input dengan batas- batas fitur yang ditentukan. Untuk 

data input atau layer yang akan dipotong dapat berupa titik, garis atau poligon, tetapi untuk pemotong 

harus layer poligon, seperti yang dilustrasikan pada gambar di bawah ini. 

 

Gambar 16. Proses Clip 
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1. Sama seperti langkah-langkah pada bagian Buffer, pertama Add Layer Penggunaan Lahan 

(“lu_jabar.shp”). 

 

Gambar 17. Gambar file shp yang akan diolah dengan metode clip 

2. Pastikan proyeksi dalam UTM zona 48S. 

3. Ubah urutan layer agar layer “sungai_buffer” berada di atas layer “lu_jabar”. 

4. Lakukan Clip dengan Klik Vector > Geoprocessing tools > Clip. Masukkan layer penggunaan 

lahan sebagai input, dan buffer sungai sebagai overlay layer. Simpan file dengan nama 

“hasil_clip.shp”. Klik Run 

 

 

 

 

 

 

 

5. Hasil clip ditunjukkan oleh gambar berikut. Untuk melihat tabel atribut dari hasil clip dapat 

melakukan klik kanan pada layer hasil_clip > Open Attribute Table. 

Gambar 18. Gambar proses clip 

 



 

 
21 MODUL BIMTEK PENGUATAN SIMPUL JARINGAN IG| 

 

Gambar 19. Gambar hasil dari proses clip 

6. Optional: 

Jika ingin menampilkan symbology berupa gradasi warna pada setiap kategori penggunaan 

lahan, maka dapat dilakukan dengan cara: 

Klik kanan pada layer hasil_clip > Properties > Control Feature Symbology > Categorized > 

Clasify > OK 

 

Gambar 20.  Hasil menampilkan gradasi warna pada setiap kategori 

Dari hasil tersebut dapat dilihat penggunaan lahan di kawasan sempadan sungai. 
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3.3. OVERLAY (INTERSECT) 

Alat Intersect digunakan untuk memotong serta melakukan tumpang tindih (overlay) antara fitur 

input. Output fitur berupa irisan antara input fitur dan memiliki atribut gabungan dari input fitur 

(Gambar 21). Pada operasi ini input fitur harus berupa tipe polygon. 

 

Gambar 21. Proses Intersect 

1. Add Layer area wilayah kelurahan/desa (“adm_desa.shp”) dan area perkebunan 

(“kebun_utm”). 

Klik Layer > Add Layer > Add Vector Layer > pilih file > OK. 

 

2. Lakukan Intersect dengan Klik Vector > Geoprocessing tools > Intersection. Input layer (layer 

yang dipotong): adm_desa, overlay layer (layer pemotong): kebun_utm. Simpan dengan 

nama file “hasil_intersect.shp”. Klik Run. 

Gambar 22. Gambar data yang akan dilakukan proses intersect 



 

 
23 MODUL BIMTEK PENGUATAN SIMPUL JARINGAN IG| 

 

 

 

 

 

3. Hasil intersect ditunjukkan oleh gambar berikut. Untuk melihat tabel atribut dari hasil 

intersect dapat melakukan klik kanan pada layer hasil_intersect > Open Attribute Table. 

Output layer yang dihasilkan memiliki atribut dari kedua layer yang di-overlay. Dapat dilihat 

desa dan kecamatan mana saja yang memiliki jenis penggunaan lahan perkebunan/kebun. 

 

 

 

 

 

 

 

 

 

3.4. DISSOLVE 

Dissolve berfungsi untuk menyatukan batas berdasarkan pada nilai atribut. Dengan kata lain, Dissolve 

akan menggabungkan batas yang bersebelahan apabila memiliki atribut yang sama seperti yang 

digambarkan di bawah ini. 

 

Gambar 25. Proses Dissolve 

Gambar 23. Gambar proses overlay 

 

Gambar 24. Gambar hasil Overlay 
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1. Add Layer area wilayah kelurahan/desa (“adm_desa.shp”). 

Klik Layer > Add Layer > Add Vector Layer > pilih file > OK. 

 

 

 

 

 

2. Klik Vector > Geoprocessing tools > Dissolve. Input layer: isi dengan administrasi 

desa/kelurahan, Dissolve field(s): isi dengan kode field kecamatan yaitu WADMKC (untuk 

melihat kode field bisa membuka tabel atribut). Simpan layer dengan nama 

“hasil_dissolve.shp”. Klik Run. 

 

 

 

 

 

 

 

 

  

 

Gambar 26. Gambar data yang akan diolah dengan metode dissolve 

 

Gambar 27. Gambar proses dissolve 
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3. Hasil dissolve adalah sebagai berikut 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

3.5. UNION 

Alat Union digunakan untuk melakukan proses tumpang tindih (overlay) mirip seperti Intersect, tetapi 

hasil prosesnya bukan merupakan irisan seperti Intersect tetapi merupakan gabungan dari seluruh 

input data baik spasial maupun atributnya seperti yang diilustrasikan pada gmbar di bawah ini.  

 
Gambar 29. Proses Union 

1. Add Layer area rawan bencana kebakaran dan bencana banjir (“rawan bencana banjir ar.shp” 

dan “sungai buffer.shp”). 

Klik Layer > Add Layer > Add Vector Layer > pilih file > OK. 

 
Gambar 30. Gambar bahan yang akan diolah metode union 

Gambar 28. Gambar hasil Dissolve 
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2. Klik vector > geoprocessing tools > Union 

tentukan layer  

 

 

 

 

 

3. Hasil dissolve adalah sebagai berikut 

 

 

 

 

 

 

 

 

 

 

3.6. MERGE 

Alat geoprocessing Merge berfungsi untuk menggabungkan data yang mempunyai tipe data yang 

sama (titik dengan titik, garis dengan garis atau poligon dengan poligon). Data yang dihasilkan akan 

digabung menjadi satu, seperti yang diilustrasikan gambar di bawah ini.  

 
Gambar 33. Proses Merge 

Gambar 31. Gambar proses metode Union 
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Add Layer area rawan bencana kebakaran dan bencana banjir (“rawan bencana banjir ar.shp” dan 

“sungai buffer.shp”). 

Klik Layer > Add Layer > Add Vector Layer > pilih file > OK 
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IV. RANGKUMAN 

1) Alat Dissolve berfungsi untuk menyatukan batas berdasarkan pada nilai atribut 

2) Alat geoprocessing Merge berfungsi untuk menggabungkan data yang mempunyai tipe data 

yang sama.  

3) Alat Split mempunyai fungsi untuk memisahkan unsur-unsur spasial menjadi beberapa kelas 

unsur berdasarkan kolom atau field pemisah.  

4) Alat Clip mempunyai fungsi untuk memotong layer input dengan batas- batas fitur yang 

ditentukan. Untuk data input atau layer yang akan dipotong dapat berupa titik, garis atau 

poligon, tetapi untuk pemotong harus layer poligon. 

5) Alat Buffer mempunyai fungsi untuk menciptakan poligon pada jarak yang ditentukan di 

sekitar fitur, fitur ini bisa titik, garis atau polygon. 

6) Alat Intersect digunakan untuk memotong serta melakukan tumpang tindih (overlay) antara 

fitur input. Output fitur berupa irisan antara input fitur dan memiliki atribut gabungan dari 

input fitur. 

7) Alat Union digunakan untuk melakukan proses tumpang tindih (overlay) mirip seperti 

Intersect, tetapi hasil prosesnya merupakan gabungan dari seluruh input data baik spasial 

maupun atributnya. 

  



 

 
29 MODUL BIMTEK PENGUATAN SIMPUL JARINGAN IG| 

V. DAFTAR PUSTAKA 

ESRI, 2004. ArcGIS 9. Geoprocessing in ArcGIS. ESRI Press, Redlands. USA 

ESRI. 2010. Creating Geoprocessing Services Tutorial. ESRI Press, Redland. USA 

Farkas, Gabor. 2017. Practical GIS: Use tools such as QGIS, PostGIS and Geoserver. Packt Publishing. 

Mumbai 

https://desktop.arcgis.com/en/arcmap/10.6/analyze/main/what-is-geoprocessing.htm/ diakses pada 

tanggal 7 April 2020 

Prahasta, Eddy. 2009. Sistem Informasi Grografis, Konsep Konsep Dasar. Informatika, Bandung. 

Smith, Micheal; Goodchild, Michael F; Longley, Paul A. 2007, Geospatial Analysis, A Comprehensive 

Guide to Principles, Techniques and Software Tools. Fourth Edition. The Winchelsea Press, 

Winchelsea. UK. 

  

https://desktop.arcgis.com/en/arcmap/10.6/analyze/main/what-is-geoprocessing.htm/


 

 
30 MODUL BIMTEK PENGUATAN SIMPUL JARINGAN IG| 

 


